Overview: 

The IronWolf Health 01 error occurs in versions 6 and 7 of the Disk Station Manager (DSM) software from Synology. It indicates that a hard disk drive (HDD) self-test failed to complete, but not necessarily that the drive is problematic.  


Symptoms:  

  • When running the test manually:


            Test output code: 001. Unknown error occurre

  • When running the test automatically, e.g. via a monthly health report: 


Drive 4
S.M.A.R.T. Status: Normal
IronWolf Health Status: -
Bad sector count: 0
Drive reconnection count: 0
Drive re-identification count: 0


Cause: 

Problem (failed log rotation? write error?) related to a files located in: /var/log/healthtest


Workaround: 

There are a few ways to deal with this. Here are two (2): 


  • Copy the current log directory to a new location, remove the problematic files, then re-run the test manually.

            sudo cp -ra /var/log/healthtest /var/log/healthtest_old


            sudo rm -rf /var/log/healthtest/*


  • If the failure persists, run the following, then confirm the test passes: 


            dhm_tool -v 4 -d /dev/ --dhm --outputPath /var/log/healthtest/ > disk_ihm.verbose


        (Note: after the first /dev/ , specify the harddrive. e.g., if it's sata1 or sda (disk 1 in both cases) leave it as: 


            /dev/sda or /dev/sata1


        Then tail the following to confirm that the drive shows as healthy: 

        

            tail disk_ihm.verbose


        (Note: this is run from the root directory, so no need to change directories).